Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


Probleme d'URL REWRITING

Discussions Générales sur OpenCart.
N'utilisez ce forum que si vous ne trouvez pas votre sujet dans une autre section.

Probleme d'URL REWRITING

Messagepar jeromec » 01 Nov 2011, 23:22

Bonjour,
Lorsque la réécriture d'URL est désactivée sur mon site, tout se passe bien mais lorsque celle-ci est activée, je rencontre un problème sous internet Explorer 9. ( Ca a l'air de fonctionner pour Firefox 7 et ie 8, je n'ai pas essayé sur d'autres navigateurs )

Voici le problème :

Lorsque je clique directement sur un lien vers un produit, j'arrive sur la fiche de celui-ci sans problème ( par exemple à partir du module "latest" ). (L'URL est alors du genre http://www.monmagasin.fr/monproduit)

Par contre, si je suis sur la page d'une catégorie et que je clique sur un lien vers le même produit, j'arrive sur sa fiche mais elle n'est plus mise en page. (L'URL est alors du genre http://www.monmagasin.fr/macategorie/monproduit)

Voici l'URL de ma boutique http://www.lacavpar3.fr
Pour voir quand ça marche : cliquer sur un vin dans la box "les p'tits nouveaux"
et quand ça ne marche pas, sélectionner une couleur, puis choisir un vin dans la liste...

Merci de m'indiquer si vous avez une idée.
Version 1.4.9fr
Template Green-store modifié
Avatar de l’utilisateur
jeromec
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 51
Inscription: 21 Oct 2010, 21:31

Re: Probleme d'URL REWRITING

Messagepar LeorLindel » 01 Nov 2011, 23:31

Je viens de faire tous les tests et je n'ai vu aucun problème de ré-écriture. Vide le cache de ton navigateur et refais des essais.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: Probleme d'URL REWRITING

Messagepar jeromec » 02 Nov 2011, 00:04

Merci de te pencher sur ma question.
J'ai essayé de vider le cache et voilà ce que j'obtiens sous ie9 :

AVEC URL REWRITING :
Image

SANS URL REWRITING :
Image
Version 1.4.9fr
Template Green-store modifié
Avatar de l’utilisateur
jeromec
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 51
Inscription: 21 Oct 2010, 21:31

Re: Probleme d'URL REWRITING

Messagepar LeorLindel » 02 Nov 2011, 00:10

Il doit surement avoir une incompatibilité de CSS avec ie9, as-tu essayé de voir si ton CSS était conforme aux normes W3C en le validant ?
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: Probleme d'URL REWRITING

Messagepar jeromec » 02 Nov 2011, 00:42

Je suis allé voir sur le site du w3c. Il y avait pas mal d'erreurs (j'en ai corrigé certaines, ça n'a rien amélioré quant à mon problème ) mais je ne pense pas que le problème vienne de là puisque mes pages s'affichent convenablement lorsque je désactive la réécriture d'URL.

Voici le rapport du fourni par le site du W3C
http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fwww.lacavpar3.fr%2Fcatalog%2Fview%2Ftheme%2Fcavpar3std%2Fstylesheet%2Fstylesheet.css&profile=css21&usermedium=all&warning=1&vextwarning=&lang=fr
Version 1.4.9fr
Template Green-store modifié
Avatar de l’utilisateur
jeromec
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 51
Inscription: 21 Oct 2010, 21:31

Re: Probleme d'URL REWRITING

Messagepar LeorLindel » 02 Nov 2011, 00:57

Je ne disais pas que ton problème de ré-écriture dépendait de la validation W3C mais que l'affichage de ton template avec ie9, lui devait surement en dépendre.

Peut être voir chez ton hébergeur si le mod_rewrite de Apache est activé.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: Probleme d'URL REWRITING

Messagepar jeromec » 02 Nov 2011, 08:51

Bonjour!
Le mod_rewrite de Apache est bien activé.

En fait, j'ai l'impression que lorsque la réécriture d'url est activée, ce sont les url de la feuille de style, des images ( et des javascript ? ) qui ne sont plus bonnes.

Normalement, l'url des images est la suivante :
/catalog/view/theme/cavpar3std/image/exemple.jpg
mais lorsque j'active l'URL REWRITING, elle devient :
/vin_rouge/catalog/view/theme/cavpar3std/image/exemple.jpg.
Forcément, elle ne s'affichent pas.
Par contre, les images du logo et des produits, elles, s'affichent bien. ( elles ne dépendent pas de mon template... /image/data/logo.png )

Bien sûr, "vin rouge" est un exemple, ceci s'applique aux catégories, aux fabricants, etc...

Je ne vois pas ou intervient la réécriture de l'adresse de ma feuille de style, etc...

A noter : les images qui ne sont pas appelées par ma feuille de style ne s'affichent pas non plus.
Par exemple, dans mon .tpl là où j'ai tapé :
Code: Tout sélectionner
<img src="catalog/view/theme/cavpar3std/image/icone_avis.png" alt="icone avis utilisateur">

j'obtiens dans ie9, http://www.lacavpar3.fr/vin_rouge/catal ... _petit.png ( j'obtiens bien http://www.lacavpar3.fr/catalog/view/th ... _petit.png dans firefox )

A noter aussi : le temps d'afichage de la page lorsque ça ne marche pas est plus long que d'habitude. Il y a une seconde de page blanche environ entre le clic et le moment ou la page non formatée apparaît.

Dois-je faire une modification dans mon .htaccess ?
Version 1.4.9fr
Template Green-store modifié
Avatar de l’utilisateur
jeromec
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 51
Inscription: 21 Oct 2010, 21:31

Re: Probleme d'URL REWRITING

Messagepar LeorLindel » 02 Nov 2011, 09:37

Et pourquoi ne pas placer tes images dans le répertoire qui leurs sont destiné : /image/ ?

Comme cela ton chemin serai :
Code: Tout sélectionner
<img src=".../image/icone_avis.png" alt="icone avis utilisateur">
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: Probleme d'URL REWRITING

Messagepar jeromec » 03 Nov 2011, 16:29

Je croyais que les images de mon template doivent être placé dans le répertoire image du template (?).
En tous cas, ça ne règle pas mon problème.
Seuls les liens en absolu ont l'air de ne pas être affectés. Les liens en relatif dans le header sont modifiés...
Version 1.4.9fr
Template Green-store modifié
Avatar de l’utilisateur
jeromec
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 51
Inscription: 21 Oct 2010, 21:31


Retourner vers Discussions Générales

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron