Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


Mise en ligne de la boutique

Veuillez inscrire tous genres de problème que vous rencontrez à  l'installation initiale ou la mise à jour d'OpenCart

Mise en ligne de la boutique

Messagepar nico56 » 16 Nov 2011, 22:44

Bonjour,

J'essaie de mettre en ligne ma boutique sur une page perso free.
Comme conseillé dans d'autres sujets, je suis reparti d'une version vierge que j'ai copié en ftp (contenu du fichier UPLOAD).

J'obtiens un message d'erreur : "PHP5.1+ Required"

J'ai trouvé dans le sujet ci dessous qq'un qui avait eu le même problème :
http://forum.opencart-france.com/post2806.html#p2806

Le conseil était d'ajouter les lignes suivantes dans le fichier .htaccess.txt
Code: Tout sélectionner
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php


J'ai ajouté ces 2 lignes au début du fichier.
Malheureusement ça ne résout pas le message d'erreur ....

Quelqu'un a t'il une idée svp ?
D'avance merci.
Dernière édition par nico56 le 19 Nov 2011, 11:43, édité 1 fois.
opencart v1.4.9_Fr
site non hébergé (en construction)
pas de module installé
nico56
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 10
Inscription: 26 Oct 2011, 05:50

Re: Mise en ligne de la boutique

Messagepar LeorLindel » 16 Nov 2011, 23:20

Crée un fichier info.php que tu mettras à la racine de ton site et qui contiendra les lignes suivantes :
Code: Tout sélectionner
<?php
echo phpinfo();
?>

Tu appelles donc ce fichier "info.php" dans la barre d'adresse, de cette façon
http://www.tondomaine.fr/info.php
et tu verras la version de PHP utilisée.

Malgré tout je te conseille (surtout quand l'on fait une boutique sur le net) de prendre un hébergeur payant. D'une part, parce que cela fait plus sérieux vis à vis de la clientèle, puis secondement lorsque tu modifieras ton fichier htaccess.txt en htaccess. chez Free, il t"apparaîtra une erreur 500 car Free n'accepte pas les htaccess. Donc même si tu arrives à régler ce problème de version de php, d'une façon ou d'une autre, tu seras voué à d'autres problèmes.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: Mise en ligne de la boutique

Messagepar nico56 » 17 Nov 2011, 07:22

Merci pour cette réponse rapide.

Voici la version affichée lorsque j'appelle info.Php : PHP Version 4.4.3-dev ...

En fait l'hébergement via free n'était que temporaire car je n'ai pas encore défini le nom du site et j'ai besoin d'afficher le site sur le web pour un rendez vous à la CCI mardi prochain.

Connais tu une autre solution d'hébergement pour mettre temporairement et rapidement le site en ligne ?

Merci de ton aide.
opencart v1.4.9_Fr
site non hébergé (en construction)
pas de module installé
nico56
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 10
Inscription: 26 Oct 2011, 05:50

Re: Mise en ligne de la boutique

Messagepar LeorLindel » 17 Nov 2011, 10:07

Si tu avais eu un hébergement, tu aurais certainement mis une boutique vierge sur celui-ci ?
Je présume aussi que cela devait être pour appuyer ton projet et montrer les fonctionnalités de cette boutique à la CCI ?
Que celle-ci ai des articles fictifs n'a pas grande importance.

Donc, ce que tu peux faire est de leur montrer la démo d'OpenCart se trouvant à cette adresse. Que cela soit la v1.4.9 ou la dernière version, n'aura aussi aucune importance à leurs yeux. Le principal étant de leur fournir le plus d"éléments susceptibles de leur montrer que tu as un projet stable
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: Mise en ligne de la boutique

Messagepar nico56 » 19 Nov 2011, 11:41

Bonjour et merci pour ton aide.

Non mon objectif n'était pas de mettre une boutique vierge car j'ai déjà fait pas mal de modif depuis la version d'origine.

Du coup j'ai trouvé la solution pour ne pas avoir le message "PHP5.1+ Required" : il suffit de mettre uniquement le code suivant dans .htaccess :
Code: Tout sélectionner
php 1

Par contre j'ai en effet de nombreux autres messages d'erreur après ...

J'ai donc fait un tour des autres hébergeurs gratuits. Celui qui a été le plus réactif pour me créer une page perso a été http://www.franceserv.fr (quelques minutes seulement !).
J'ai créé un compte gratuit "Pack light" : compte réservé à un usage perso ce qui me convient pour l'instant car uniquement pour test.

L'installation de la boutique vierge a fonctionné du 1er coup. Aucun message d'erreur !
J'ai ensuite chargé mon code et ma base de donnée. Tout fonctionne très bien.
opencart v1.4.9_Fr
site non hébergé (en construction)
pas de module installé
nico56
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 10
Inscription: 26 Oct 2011, 05:50


Retourner vers Soutien Installation et Mise à Jour

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron