Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


"Session invalide" dans l'admin après réinstallation

Soutien général pour les problèmes techniques avec OpenCart

Re: "Session invalide" dans l'admin après réinstallation

Messagepar LeorLindel » 17 Jan 2013, 03:39

Déplace ta boutique à la racine et modifies tes chemins dans les fichiers config.php et cela devrait fonctionner. Modifies aussi le fichier htaccess.txt en .htaccess
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: "Session invalide" dans l'admin après réinstallation

Messagepar Deadpoule » 17 Jan 2013, 03:42

C'est étrange tout de même, ça fonctionnait très bien sur mon ancien hébergement...
Qu'entends-tu par htaccess.txt ??? Je n'en vois pas
OpenCart : Version 1.5.4
Hébergeur : OVH
Php 5
Deadpoule
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 47
Inscription: 01 Avr 2012, 23:05

Re: "Session invalide" dans l'admin après réinstallation

Messagepar LeorLindel » 17 Jan 2013, 03:49

Où as-tu eu la version d'Opencart que tu as ?
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: "Session invalide" dans l'admin après réinstallation

Messagepar Deadpoule » 17 Jan 2013, 03:52

Elle vient d'ici
OpenCart : Version 1.5.4
Hébergeur : OVH
Php 5
Deadpoule
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 47
Inscription: 01 Avr 2012, 23:05

Re: "Session invalide" dans l'admin après réinstallation

Messagepar LeorLindel » 17 Jan 2013, 03:59

Je ne parle pas du pack de langue mais de la version d'Opencart.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: "Session invalide" dans l'admin après réinstallation

Messagepar Deadpoule » 17 Jan 2013, 04:04

Eh bien tout ce que j'ai retrouvé dans mon historique de navigation c'est ce lien.
OpenCart : Version 1.5.4
Hébergeur : OVH
Php 5
Deadpoule
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 47
Inscription: 01 Avr 2012, 23:05

Re: "Session invalide" dans l'admin après réinstallation

Messagepar LeorLindel » 17 Jan 2013, 04:09

Dans le répertoire upload se trouve bien un fichier .htaccess.txt, non ?
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: "Session invalide" dans l'admin après réinstallation

Messagepar Deadpoule » 17 Jan 2013, 12:44

Ok je vois, mon ordinateur n'était pas configuré pour lire les fichiers cachés. J'ai donc enfin vu ce fichier htaccess.txt que j'ai uploadé sur mon serveur à la racine du dossier ocart et que j'ai renommé en .htaccess. Mais ça ne change rien au soucis...
Va-t-il vraiment falloir que je déplace mon installation à la racine de fredzcrea.com ? Parce que bon, ma précédente install fonctionnait très bien dans un sous-dossier. Et pour ce qui est de cette install-ci, avant que j'importe convenablement ma vieille BDD, j'avais encore accès au site, même s'il était présent dans le dossier ocart...
OpenCart : Version 1.5.4
Hébergeur : OVH
Php 5
Deadpoule
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 47
Inscription: 01 Avr 2012, 23:05

Re: "Session invalide" dans l'admin après réinstallation

Messagepar LeorLindel » 17 Jan 2013, 13:19

Y a t-il un intérêt profond pour que cela soit sur ocart/ ?
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: "Session invalide" dans l'admin après réinstallation

Messagepar Deadpoule » 17 Jan 2013, 20:40

Nan mais ouais, je te suis dans l'idée : il n'y a pas d'intérêt majeur à ce que se soit dans un sous-dossier. Alors donc selon toi, qu'est-ce qui fait que cette arborescence fasse bugger le site ?
OpenCart : Version 1.5.4
Hébergeur : OVH
Php 5
Deadpoule
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 47
Inscription: 01 Avr 2012, 23:05

Re: "Session invalide" dans l'admin après réinstallation

Messagepar LeorLindel » 17 Jan 2013, 20:58

Je n'ai nullement dit que l'arborescence faisait bugger, j'ai simplement demandé pourquoi mettre un sous-dossier ?

Pour résumer, refaire une installation dans la racine = url/install/

Procédure détaillée.

1 - supprimer tous les fichiers du serveur via FTP
2 - transférer le pack de la v1.5.4 (admin, catalog, download, image, etc...) à la racine sur le serveur via FTP
3 - aller à l'url et procéder à l'installation > url/install
4 - paramétrer l'installation comme sur l'installation locale.
5 ' aller dans la BDD et supprimer toutes les tables de la BDD
6 - exporter la BDD de l"ancienne BDD locale.
7 - ne pas oublier de transférer les images de l'installation locale via FTP sur le serveur.
8 - renommer le fichier htaccess.txt en .htaccess

Tout devrait fonctionner, si ce n'est pas le cas, j'abandonne.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: "Session invalide" dans l'admin après réinstallation

Messagepar Deadpoule » 17 Jan 2013, 21:03

Juste pour info, l'installation que je cherche à restaurer n'était pas locale mais en ligne dans mon ancien plan d'hébergement (mais toujours chez le même hébergeur). Ça change quelque chose ?
Encore merci pour ton soutien !
OpenCart : Version 1.5.4
Hébergeur : OVH
Php 5
Deadpoule
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 47
Inscription: 01 Avr 2012, 23:05

Re: "Session invalide" dans l'admin après réinstallation

Messagepar LeorLindel » 17 Jan 2013, 21:08

Cette nouvelle installation te permettra d'avoir une installation à la racine plutôt que dans un sous-dossier et nécessitera moins de bidouillage en tous sens.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4228
Inscription: 19 Fév 2010, 13:44
Localisation: Lutéce

Re: "Session invalide" dans l'admin après réinstallation

Messagepar Deadpoule » 17 Jan 2013, 21:14

Oui, visons la simplicité. Ok, merci ;)

EDIT :

Rebelotte : une fois toutes les démarches entreprises fredzcrea.com et fredzcrea.com/admin mènent à une page blanche...

Tout ce que je peux dire, c'est que si j'avais voulu configurer la nouvelle install exactement comme l'ancienne, j'aurais dû appeler ma nouvelle BDD ainsi que son utilisateur de la même manière que pour l'ancienne BDD, c'est à dire fredzcre_oc2012 ce qui est impossible puisque à l'époque ma cliente avait son propre plan d'hébergement. Ce pourquoi sa BDD portait le préfixe fredzcre_.
À l'heure actuelle, son nom de domaine est accolé à un domaine compagnon de mon espace perso. Alors la nouvelle BDD (celle de l'install bugée en ligne actuellement) porte le préfixe dlmulti1_

Je ne sais pas si cela a une incidence, mais bon je préférais le signaler ici. Si ça se trouve, je pourrais restaurer mon install que si ma cliente commande sa propre solution d'hébergement...

Merci tout du moins pour toute l'aide que tu m'as offerte. Tu as été très patient :-D
OpenCart : Version 1.5.4
Hébergeur : OVH
Php 5
Deadpoule
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 47
Inscription: 01 Avr 2012, 23:05

Précédente

Retourner vers Soutien Général

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron